February Plug-In Update Round-Up

In preparation for my upcoming Learn OmniFocus workflow session, I’ve been steadily working on updating my existing set of OmniFocus Plug-Ins. Here is a summary of the updates for the month of February, with even more coming down the pipeline in March.

Newly Released OmniFocus Plug-Ins

Open URL From Note (v 1.4.1)

I released this new plug-in which opens URLs from notes, and allows the user to choose the behaviour for OmniFocus links. I’ve assigned this to ⌥ + U and use it all the time! Extra tip: if you need to open certain links in different browsers or applications, check out OpenIn (which is included as part of a SetApp subscription).

Agendas (v 1.7.0)

This plug-in was commissioned by another OmniFocus user, and allows for the management of ‘event’ and ‘agenda’ tasks. Tasks can be added to the ‘Agenda’ for another ‘event’ task, and once that event task is completed the user is prompted to process its agenda items.

Other Plug-In Updates

As well as the changes called out below, a number of actions across all of my plug-ins have had their validation updated so that they are always available, where previously they could only be run while nothing was selected. This is a result of the new ‘Show Action in Share Sheet’ preference that is available in the exciting new OmniFocus 4 beta.

Reorder Tags (v 3.0.1)

I released v3 of the ‘Reorder Tags’ plug-in, which contains a number of improvements:

  • A ‘Reorder Tags for All Tasks’ action has been added, along with a Keyboard Maestro macro to run this action intermittently.
  • The performance has been dramatically improved once tags are already in order. Although the action may take a few minutes to run on the entire database the first time, it should run much quicker subsequently.
  • There is now a ‘Preferences’ action for configuring any ‘first’ or ‘last’ tags; if that is relevant to your set-up this will replace the previous config file that needed to be manually edited.

It also fixes a bug from previous versions where ‘on-hold’ tags were not considered in the tag order.

Templates (v 1.16.1)

On-hold templates are no longer shown in the ‘Create From Template’ drop-down menu. They can still be used to create templates programatically, e.g. by using other plug-ins.

A couple of other bug fixes:

  • Previously, active projects inside dropped folders (e.g. the templates folder!) were shown in the destination list for the ‘Create from Template’ menu. These are now excluded from the list.
  • Templates that were ‘on-hold’ are now made active after creation, where in some cases they weren’t previously.

Defer Tags (v 3.3.1)

A Keyboard Maestro macro for updating deferred tags was added to the repo, and a bug (that caused errors if a previously-scheduled tag had been deleted) was fixed.

Move to Action Group (v 3.1.1)

A couple of bugs were fixed, and a new ‘Go To Last Moved’ action was added.

Synced Preferences (v 4.7.2)

  • The view resulting from the ‘Go To Synced Preferences’ action in the Synced Preferences plug-in has been improved.

7 thoughts on “February Plug-In Update Round-Up”

  1. Hi Kaitlin, Will you be updating any of these for OmniFocus 4? I have been using the TestFlight version and unfortunately the dependency Plug-In doesn’t seem to be working as intended. Thanks!!!

    1. Hi David! These should all in fact be working for OmniFocus 4 already, theoretically – I’m on the TestFlight too but not having and problems. What issue are you seeing with the Dependency plug-in? It’s possible I made a change that inadvertently broke something, but I’d be happy to help you get to the bottom of it!

      1. Whenever I add a prerequisite marker on a task, it adds that prerequisite marker tag to the whole project that task is in…not sure what is causing it :/

        1. Ah! I believe I know what that problem will be! In OF4 on iOS, currently when a filter is applied in a perspective, that project that’s selected in the filter is treated as ‘selected’ by Omni Automation (which is why the tag is being applied).

          I think this is potentially confusing and I have a note to submit feedback about it, but in the meantime the best workaround is probably to add the prerequisite marker tag in the same way as you would any other tag. That said, you are going to encounter the same issue if you have a filter applied when you use the next, ‘Add Prerequisite’, action which is more difficult to work around, other than by clearing the filter, unfortunately.

          Sorry I can’t be more help!

          1. That worked! Thanks so much! Also, one other question – I can do it from my iPad, but on my iPhone, I can’t figure out how to “Complete for Prerequisite” on a task – any insight you can share?

          2. Hi David! I’m sure we can work that out. How are you running the ‘Complete for Prerequisite’ action on the iPad? Are you using the ‘Automation’ menu or are you using the share sheet? Either of those should work on the iPhone as well, but if you prefer to use the Automation menu you might need to turn on ‘Developer Mode’ in the Settings menu – then to get to the Omni Automation menu in the OF4 TestFlight you need to click on the three dots on the top right. Not sure if that helps, but let me know some more information if not and we’ll see if we can get to the bottom of it. 🙂

          3. Ahhhh, I didn’t realize it was within the three dots on the top right, thanks so much! You rock!

Leave a Reply to David Cancel reply